500 Errors Across Jobber

Incident Report for Jobber

Resolved

We have fully investigated, and are no longer experiencing with 500 errors across Jobber. Our Engineering team is actively discussing how to prevent future disruptions similar to this one.

If you continue to experience issues, please reach out to support@getjobber.com.

Thank you for your patience as we resolved this issue!
Posted Mar 06, 2025 - 11:26 MST

Investigating

We are investigating an issue with 500 errors across Jobber.
We will update as soon as we have any more information.


We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Mar 06, 2025 - 11:21 MST
This incident affected: Web Application (Jobber Online).