Email Delivery Issues via Outlook

Incident Report for Jobber

Resolved

We have fully investigated, and are no longer experiencing issues with Outlook. If you continue to experience issues with sending or receiving emails, please reach out to support@getjobber.com.
Thank you for your patience as we resolved this issue!
Posted Jan 23, 2026 - 07:00 MST

Investigating

We are currently investigating an issue with Outlook. This issue may affect your ability (or your customers' ability) to receive emails. We continue to monitor Outlook's progress in resolving the issue while working to reduce the impact wherever possible.

We appreciate your patience and will continue to share updates as soon as new details become available.
Posted Jan 22, 2026 - 16:09 MST
This incident affected: Third Party Services (Email Services).