Degraded Performance
Incident Report for Jobber
Resolved
This incident has been resolved and performance has returned to normal.
Posted Nov 15, 2024 - 13:11 MST
Identified
We've identified the issue and performance is improving.
Posted Nov 15, 2024 - 13:09 MST
Investigating
We are seeing some degraded performance and parts of Jobber may load slower than normal. We are investigating and working towards a fix.
Posted Nov 15, 2024 - 13:03 MST
This incident affected: Web Application (Jobber Online) and API & Mobile Application (Jobber App).