Performance Issues with payments processed through Card readers and Tap ...

Incident Report for Jobber

Resolved

We have fully investigated, and are no longer experiencing issues with payments processed through Tap to Pay and card readers.
Our Engineering team is actively discussing how to prevent future disruptions similar to this one.
If you continue to experience issues with collecting payments through Tap to Pay or Card Readers please reach out to support@getjobber.com.
Thank you for your patience as we resolved this issue!
Posted Dec 11, 2025 - 14:39 MST

Monitoring

We are continuing to monitor the issue affecting payments processed through Tap to Pay and card readers.

We greatly appreciate your patience, and will update as soon as the issue has been resolved.
Posted Dec 11, 2025 - 14:12 MST

Update

We are continuing to investigate this issue.
Posted Dec 11, 2025 - 10:39 MST

Update

We are continuing to investigate this issue.
Posted Dec 11, 2025 - 10:38 MST

Investigating

We’re currently investigating an issue affecting payments processed through Tap to Pay and card readers, which may impact any customers using these methods. Payments collected through Client hub, as well as payments entered manually in the app or on Jobber.com, are not affected.

We recommend using one of the methods above while we work on a solution. We’ll share an update as soon as more information is available. We know how important reliable payments are for your business, and we appreciate your patience while we work to resolve this quickly.
Posted Dec 11, 2025 - 10:34 MST
This incident affected: API & Mobile Application (Jobber App).