Performance issues with Automations and Campaigns being automatically sent out

Incident Report for Jobber

Resolved

We have fully investigated, and are no longer experiencing an issue with our Automations (Invoice or Quote Follow Ups) or Automated Campaigns being sent out. Our Engineering team is actively discussing how to prevent future disruptions similar to this one.
If you see any follows up that were not sent out during the afternoon of Dec 3rd to the morning of Dec 4th, please send them out manually if needed. If you are still running into issues please reach out to support@getjobber.com.
Thank you for your patience as we resolved this issue!
Posted Dec 04, 2025 - 09:03 MST

Update

We are continuing to investigate this issue.
Posted Dec 04, 2025 - 07:34 MST

Investigating

We are investigating an issue with Automations (Quote and Invoice Follow Ups) and Campaigns being automatically sent out. These scheduled emails may not be sent out. This may affect some users.
We recommend sending any follows up manually at the moment.
We will update as soon as we have any more information.
We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Dec 04, 2025 - 07:26 MST
This incident affected: Web Application (Jobber Online).