Jobber Payments delay in updating items

Incident Report for Jobber

Resolved

We have fully investigated the issue with Jobber Payments update delays.
There may be remaining delays on updates to payments/payouts as items are re-processed over the next two hours.
Instant Payouts may also show that no funds are available in this timeframe as a result.

Please do not re-attempt to collect payment on previously paid items during this time to avoid duplicated payment collection.

Our Engineering team is actively discussing how to prevent future disruptions similar to this one.
If you continue to experience issues with Jobber Payments after 8:00 pm ET, please reach out to support@getjobber.com.
Thank you for your patience as we resolved this issue!
Posted Sep 27, 2023 - 15:58 MDT

Investigating

We are investigating an issue with Jobber Payments. This may impact updates on payments within the application.
Users may see delays in invoices being marked as paid, payout status updates, and other payment related actions.
We recommend to not re-attempt processing of items as they will be retried once the issue is resolved.
We will update as soon as we have any more information.
We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Sep 27, 2023 - 15:25 MDT
This incident affected: Third Party Services (Jobber Payments).