Quotes Unable to Convert to Jobs
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 27, 2018 - 13:58 MDT
Identified
Jobber is currently experiencing an incident affecting generating Jobs from Quotes, among other issues. We believe we have identified the issue and are working on a fix.
Posted 9 months ago. Mar 27, 2018 - 13:44 MDT