Jobber Payments on mobile app

Incident Report for Jobber

Resolved

This issue has been resolved and the Jobber Payments section is appearing again in the mobile app.
Posted Apr 21, 2025 - 14:28 MDT

Identified

We have identified the cause for the Jobber Payments section missing in the mobile app.
We are working to restore this section on the mobile app shortly.

In the meantime, Jobber Payments settings can be accessed through Jobber Online.
Posted Apr 21, 2025 - 11:12 MDT
This incident affected: Third Party Services (Jobber Payments) and API & Mobile Application (Jobber App).