Users may see an error when attempting to log into Jobber

Incident Report for Jobber

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 13:15 MDT

Monitoring

We are seeing improvements and successful Jobber logins. We are continuing to monitor to ensure the issue is fully resolved.

We greatly appreciate your patience, and will update as soon as the issue has been resolved.
Posted Mar 25, 2025 - 12:53 MDT

Identified

We have identified the cause of an issue affecting the ability to log into Jobber. Our team is actively working on resolving this issue, and will continue to update this page as soon as possible.

If you are already logged in, you should be able to continue using Jobber as usual.

We greatly appreciate your patience.
Posted Mar 25, 2025 - 12:38 MDT
This incident affected: Web Application (Jobber Online) and API & Mobile Application (Jobber App).