Error viewing and completing Job Forms through Visits in Jobber Online

Incident Report for Jobber

Resolved

We have resolved the issue that was causing errors when attempting to view and edit job forms through visits in Jobber Online.
Posted Aug 27, 2025 - 13:22 MDT

Identified

We are aware of an issue causing an error when trying to view and complete Job Forms through Visits in Jobber Online. We are looking into a fix as soon as possible.
Posted Aug 27, 2025 - 12:49 MDT
This incident affected: Web Application (Jobber Online).