Delays or timeouts when logging into Jobber
Incident Report for Jobber
Resolved
We have fully investigated, and are no longer experiencing issues with logins. Our Engineering team is actively discussing how to prevent future disruptions similar to this one.

If you continue to experience issues with logging into Jobber or accessing the Home page, please reach out to support@getjobber.com.

Thank you for your patience as we resolved this issue!
Posted Jun 27, 2024 - 14:35 MDT
Identified
We have identified the cause of the issue affecting logins for some users and are working towards a resolution.

Our team will continue to update this page as soon as possible with any further updates.
Posted Jun 27, 2024 - 11:30 MDT
Investigating
We are seeing increased loading times or timeout errors when logging into Jobber and accessing the Home page. We are investigating the issue.

If you are encountering this error, we recommend using the url https://secure.getjobber.com/clients to bypass the Home page.

We will update as soon as we have any more information.

We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Jun 27, 2024 - 10:54 MDT
This incident affected: Web Application (Jobber Online).