Email Deliverability Issues
Incident Report for Jobber
Resolved
We have fully investigated, and are no longer experiencing email deliverability issues. Our Engineering team is actively discussing how to prevent future disruptions similar to this one.

If you continue to experience issues with your email please reach out to support@getjobber.com.

Thank you for your patience as we resolved this issue!
Posted Apr 22, 2024 - 15:21 MDT
Monitoring
We have identified and addressed the problem and are working towards ensuring AOL/Yahoo is aware that we’ve solved the problem.

Although there might be still some users affected, we are seeing improvements in emails being delivered.

This issue has not impacted the security of Jobber’s systems or your data. Learn more about Security at Jobber - https://getjobber.com/security/

We are actively monitoring the situation while we work with our partners to ensure a full resolution. We greatly appreciate your patience and will update you as soon as the issue has been resolved.
Posted Apr 18, 2024 - 09:43 MDT
Investigating
Our team has received reports that users using AOL/Yahoo email servers (including ATT, Verizon and Rogers) are facing deliverability errors. We are actively monitoring the situation while we work with our partners to ensure a resolution. Thank you for your patience and understanding!
Posted Apr 15, 2024 - 08:15 MDT
This incident affected: Third Party Services (Email Services).