Deliverability Issues to Microsoft 365 Email Addresses
Incident Report for Jobber
Resolved
Over the last 48 hours, deliverability has returned to normal for Microsoft 365 inboxes. Our team is continuing to monitor the situation closely.

If you have any questions please reach out to our support team.
Posted Mar 22, 2024 - 10:03 MDT
Monitoring
We have seen significant improvement in deliverability to Microsoft 365 inboxes over the last 24 hours. Our team is continuing to monitor the situation closely for any new developments and are doing all we can to ensure things continue trending positively.
Posted Mar 21, 2024 - 09:54 MDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 15, 2024 - 10:10 MDT
Identified
Our team has received reports from users of Microsoft 365 about not receiving emails. We believe these messages are being sent but are being quarantined. You can read more details on how to remove messages from quarantine here: https://help.getjobber.com/hc/en-us/articles/22099305819543-Microsoft-365-and-Outlook-Email-Delivery-Issues

In the meantime, our support team is accessible through other channels. For more details, please review our help article here: https://help.getjobber.com/hc/en-us/articles/360008966513-How-to-Get-Help.

We will update you as soon as we have more information.

We understand how important it is for Jobber to run your business smoothly, and we greatly appreciate your patience during this time.
Posted Mar 14, 2024 - 13:44 MDT
This incident affected: Third Party Services (Email Services).