Reduced Functionality for Users of IE11
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted 8 months ago. Apr 24, 2018 - 11:48 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 8 months ago. Apr 24, 2018 - 11:29 MDT
Investigating
Users of IE11 are currently experiencing significantly reduced functionality in Jobber Online. We are currently investigating.
Posted 8 months ago. Apr 24, 2018 - 10:45 MDT