Users are unable to call Jobber's Product Support or Sales lines
Incident Report for Jobber
Resolved
We have fully investigated alongside our third-party service provider, and are no longer experiencing issues with our phone lines.
Both inbound and outbound phone lines are fully operational.
Thank you for your patience as we resolved this issue!
Posted Jan 23, 2025 - 07:03 MST
Monitoring
We are continuing to monitor the issue with our phone service provider.
Calls are now being placed successfully both outbound and inbound to our phone lines, and we will continue to monitor this for any changes to the quality.
We greatly appreciate your patience, and will update as soon as the issue has been fully resolved
Posted Jan 23, 2025 - 06:00 MST
Update
We are currently experiencing intermittent outages with inbound and outbound calling. This issue is due to an impairment with one of our third-party service providers. We are actively monitoring the situation and working closely with the provider to ensure a resolution as quickly as possible.

In the meantime, we recommend reaching out to our team via live chat or email at sales@getjobber.com or support@getjobber.com if you need immediate assistance.
Posted Jan 22, 2025 - 13:53 MST
Update
We are continuing to monitor the issue with our phone service provider.
Calls are now being placed successfully both outbound and inbound to our phone lines.
We will continue to monitor this for any changes to the quality.
We greatly appreciate your patience, and will update as soon as the issue has been resolved.
Posted Jan 22, 2025 - 13:34 MST
Investigating
We are investigating an issue with our phone provider which is preventing all inbound and outbound calls from taking place.
We recommend reaching our team via live chat or email (sales@getjobber.com or support@getjobber.com)
We will update as soon as we have any more information.
We understand how important it is for you to get support with your business needs, so we greatly appreciate your patience at this time.
Posted Jan 22, 2025 - 12:41 MST
This incident affected: Jobber Support (Phone Support).