Intermittent Search Issues
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 20:04 MST
Investigating
We are currently investigating this issue.
Posted Feb 11, 2020 - 18:56 MST
This incident affected: Website and Application Servers.