We have fully investigated, and are no longer experiencing issues with de-selecting the 'Same as property address' check box while creating/ editing a Client. Our Engineering team is actively discussing how to prevent future disruptions similar to this one. If you continue to experience issues with this please reach out to support@getjobber.com. Thank you for your patience as we resolved this issue!
Posted Jan 20, 2026 - 11:12 MST
Investigating
We are investigating an issue with updating existing Client's and creating new Client's where the Billing Address is the same as the Property Address. This may affect all users with deselecting the 'same' box while on the edit Client Page. We recommend using the App to create/ edit a Client with the same billing address and property address to be able to select the check box. We will update as soon as we have any more information. We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Jan 20, 2026 - 10:58 MST
This incident affected: Web Application (Jobber Online).