This issue has now been resolved, and all affected systems are operating normally. Our Engineering team is actively discussing how to prevent similar disruptions in the future. If you continue to experience any issues, please contact us at support@getjobber.com.
We understand how critical Jobber is to your business and appreciate your patience while we worked to resolve this.
Posted Jul 15, 2026 - 15:55 MDT
Identified
We’ve identified the cause of the issue affecting image previews in Notes and other areas of Jobber for some users. Our team is actively working on a fix to resolve this as quickly as possible. We’ll continue to provide updates as progress is made. We understand how critical Jobber is to your business and appreciate your patience.
Posted Jul 15, 2026 - 13:19 MDT
Investigating
We're currently investigating an issue affecting image previews in Notes and other areas of Jobber, which may impact some users when uploading or viewing photos taken on an iPhone in HEIC format. Affected images display as grey thumbnails and download instead of opening in the image viewer. Our team is actively working to identify the cause. We'll share updates soon. In the meantime, you can change your iPhone camera to capture photos in JPEG instead of HEIC by opening Settings > Camera > Formats and selecting Most Compatible — any new photos you take will preview correctly in Jobber. We understand how critical Jobber is to your business and appreciate your patience.
Posted Jul 15, 2026 - 06:14 MDT
This incident affected: Web Application (Jobber Online).