Issue with Client Edit in Jobber Online interface

Incident Report for Jobber

Resolved

We have resolved the issue that was causing errors when attempting to edit client information in Jobber Online.
Posted Aug 27, 2025 - 10:47 MDT

Identified

We are aware of issues with editing Client information in Jobber Online, and are looking into a fix as soon as possible. For now, Client edits can still be performed in Jobber Mobile App.
Posted Aug 27, 2025 - 10:30 MDT
This incident affected: Web Application (Jobber Online).