We are currently experiencing a service disruption
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 15:28 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2020 - 14:10 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 29, 2020 - 13:48 MDT
This incident affected: Website and Application Servers.