Performance Issues with our New QuickBooks Sync Activity page

Incident Report for Jobber

Resolved

We have fully investigated, and are no longer experiencing performance issues with our new QuickBooks sync activity page. Our Engineering team is actively discussing how to prevent future disruptions similar to this one.
Thank you for your patience as we resolved this issue!
Posted Oct 28, 2025 - 09:01 MDT

Investigating

We are investigating an issue with our New QuickBooks sync activity page. This may affect some users with accessing the QuickBooks sync activity page.
We will update as soon as we have any more information.
We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Oct 28, 2025 - 08:04 MDT
This incident affected: Third Party Services (QuickBooks Online Integration).