Unable to Create Jobs and Work Requests
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted Jun 12, 2020 - 13:18 MDT
Identified
Jobber is currently experiencing an incident affecting generating Jobs with job forms and work requests, among other issues. We believe we have identified the issue and are working on a fix.
Posted Jun 12, 2020 - 13:09 MDT
This incident affected: Web Application (Jobber Online).