Mobile App Crashing
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted May 06, 2020 - 17:48 MDT
Investigating
A third-party provider pushed a change that is causing our mobile app to crash upon opening. We are working to restore functionality as soon as possible.
Posted May 06, 2020 - 17:39 MDT