We have fully investigated, and are no longer experiencing with adding a new credit card or updating a credit card for your subscription payment.
Our Engineering team is actively discussing how to prevent future disruptions similar to this one.
If you continue to experience issues with (symptom/known issue) please reach out to support@getjobber.com.
Thank you for your patience as we resolved this issue!
Posted Apr 22, 2025 - 14:01 MDT
Update
We are investigating an issue with adding a new credit card or updating a credit card for your subscription payment. This may affect some users with their subscription payments. We will update as soon as we have any more information. We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Apr 22, 2025 - 13:51 MDT
Investigating
We are investigating an issue with adding a new credit card or updating a credit card for your subscription payment. This may affect some users with thier subscription payments. We will update as soon as we have any more information. We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Apr 22, 2025 - 13:39 MDT
This incident affected: Third Party Services (Web Application Subscriptions).