Jobber Not Loading

Incident Report for Jobber

Resolved

We have fully investigated, and are no longer experiencing issues with Jobber loading. Our Engineering team is actively discussing how to prevent future disruptions similar to this one.
Posted Apr 10, 2025 - 11:50 MDT

Monitoring

We are seeing Jobber return to normal and are monitoring closely.
Posted Apr 10, 2025 - 11:38 MDT

Investigating

We are experiencing issues across the board with loading Jobber. We are all hands on deck working toward a fix as soon as possible.
Posted Apr 10, 2025 - 11:25 MDT
This incident affected: Web Application (Jobber Online).