We have resolved the issue affecting work request forms, and service is now operating as expected. Our team is reviewing the incident to help prevent similar disruptions in the future.
If you continue to experience any issues with work request forms, please reach out to us at support@getjobber.com so we can assist.
Thank you for your patience while we worked to restore normal performance.
Posted Dec 02, 2025 - 09:38 MST
Investigating
We are currently investigating an issue that is affecting some customers when editing the work request form. This may cause unexpected behaviour when saving or updating form fields. Our team is working to identify the cause and restore normal performance as quickly as possible.
We will share another update as soon as we have new details. We know how important it is for Jobber to run smoothly for your business, and we appreciate your patience while we work to resolve this.
Posted Dec 02, 2025 - 09:29 MST
This incident affected: Web Application (Jobber Online).