Service disruption
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted Mar 12, 2021 - 11:33 MST
Monitoring
We have identified the issue and are monitoring performance as it improves.
Posted Mar 12, 2021 - 11:05 MST
Investigating
We are currently investigating this issue and will update this page as we have more information.
Posted Mar 12, 2021 - 10:55 MST
This incident affected: Application Servers.