Performance issues with logging into Jobber Online

Incident Report for Jobber

Resolved

We are no longer seeing issues with logging in to Jobber.
If you continue to experience issues with logging in, please reach out to support@getjobber.com.
Thank you for your patience as we resolved this issue!
Posted Jun 12, 2025 - 15:39 MDT

Investigating

We are investigating an issue with the the Jobber Online log in page. This may affect some users.
We will update as soon as we have any more information.
We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Jun 12, 2025 - 14:53 MDT
This incident affected: Web Application (Jobber Online).