Delays In Processing Times Across Jobber
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted Jan 28, 2025 - 15:30 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 28, 2025 - 14:14 MST
Investigating
We are seeing some delays in data being processed across Jobber. Our team is looking into the root cause and will provide updates as we learn more.
Posted Jan 28, 2025 - 13:31 MST
This incident affected: Web Application (Jobber Online).