Service Disruption
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 17:03 MDT
Monitoring
We believe system issues are resolving, and continuing to monitor.
Posted Jul 17, 2020 - 15:56 MDT
Investigating
Jobber is experiencing sporadic system-wide issues. Early investigation indicates a wider issue. We are continuing to investigate.
Posted Jul 17, 2020 - 15:40 MDT