Error when creating Quotes in Jobber Online

Incident Report for Jobber

Resolved

We have implemented a fix. Users will no longer receive errors during quote creation in Jobber Online.
To pick up the fix we have just deployed, please refresh your page.
Thank you for your patience as we worked on a solution.
Posted Nov 13, 2025 - 09:12 MST

Update

We are continuing to work on a fix for this issue.
Posted Nov 13, 2025 - 08:35 MST

Identified

We are aware that some users are receiving an error when creating Quotes in Jobber Online. We have identified the source of the issue and are implementing a fix. As a temporary workaround, please use the Jobber App.
Posted Nov 13, 2025 - 08:32 MST
This incident affected: Web Application (Jobber Online).