Cloudflare issue is blocking access to Jobber Online

Incident Report for Jobber

Resolved

The third-party service has resolved the outage that was impacting customer websites and automated call services.
Posted Nov 18, 2025 - 08:08 MST

Update

We continue to experience intermittent issues with our customer websites and automated call services due to a widespread, ongoing third-party service outage. We will continue to update as more information becomes available.
Posted Nov 18, 2025 - 06:53 MST

Monitoring

Jobber is experiencing intermittent issues due to a widespread, ongoing third-party service outage.
Posted Nov 18, 2025 - 06:20 MST

Investigating

We are currently aware of an issue with Cloudflare which is impacting the ability to access Jobber Online. The Jobber Mobile App is not affected, so we advise that you use that as a temporary workaround.
Posted Nov 18, 2025 - 06:04 MST
This incident affected: Web Application (Jobber Online).