Reports may be incorrect

Incident Report for Jobber

Resolved

We have fully investigated and are no longer experiencing issues with incorrect Jobber Payment fee amounts being displayed in reports. Our Engineering team is actively discussing how to prevent future disruptions similar to this one.

If you continue to experience issues, please reach out to support@getjobber.com.

Thank you for your patience as we resolved this issue!
Posted Mar 13, 2025 - 09:40 MDT

Identified

We are aware that the fees taken by Jobber Payments are appearing incorrectly in certain reports. We are in the process of fixing this issue to ensure fees are reported correctly.

This should not impact the amount of fees that were taken on the transactions.
Posted Mar 13, 2025 - 08:59 MDT
This incident affected: Web Application (Jobber Online) and Third Party Services (Jobber Payments).