Homepage dashboard insights not loading
Incident Report for Jobber
Resolved
This incident has been resolved.
Posted May 17, 2023 - 09:12 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 16, 2023 - 16:55 MDT
Investigating
We are investigating an issue with the homepage dashboard insight not loading. This may be affecting all users.
We will update as soon as we have any more information.
We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted May 16, 2023 - 16:41 MDT
This incident affected: Web Application (Jobber Online).