Redirect loop in Jobber Online when accessing some pages

Incident Report for Jobber

Resolved

We have resolved the issue that was impacting page loading of Clients list, and creation of Requests & Jobs in Jobber Online.
Posted Oct 28, 2025 - 12:05 MDT

Identified

We have identified the source of the page loading issue and a fix is being implemented.
Posted Oct 28, 2025 - 09:15 MDT

Investigating

We are investigating an issue with page loading. This may affect some users who are attempting to view Clients list or create Requests & Jobs in Jobber Online.
We recommend that you use Jobber Mobile App for the meanwhile.
We will update as soon as we have any more information.
We understand how important it is for Jobber to be running smoothly for your business, so we greatly appreciate your patience at this time.
Posted Oct 28, 2025 - 07:42 MDT
This incident affected: Web Application (Jobber Online).